Requirements of Windows Server Update Services (WSUS) 3.0

Microsoft Windows Server Update Services 3.0  enables information technology administrators to deploy the latest Microsoft product updates to computers running Microsoft Windows Server 2003, Windows Server® 2008, Windows Vista®, Microsoft Windows XP with Service Pack 2, and Windows 2000 with Service Pack 4 operating systems. By using WSUS, administrators can fully manage the distribution of updates that are released through Microsoft Update to computers in their network.

WSUS downloads these updates from the Microsoft Update website and then distributes them to computers on a network. WSUS runs on Windows Server and is free to licensed Microsoft customers.

WSUS 3.0 System Requirements:

  • WSUS server minimum hardware requirements
  • WSUS server software requirements
  • WSUS database requirements
  • WSUS Administration Console software requirements
  • WSUS client system requirements

WSUS server minimum hardware requirements

To serve as a WSUS server,it should meet the following hardware requirements:

  • The CPU, graphics card, memory, and other hardware components must be sufficient to run the installed operating system.
  • I/O subsystem: Fast ATA/IDE 100 hard drive or equivalent SCSI drive is recommended.
  • Network adapter: Minimum 10 MB; however, 100 MB or more is recommended.
  • Both the system partition and the partition on which you install WSUS 3.0 SP2 must be formatted with the NTFS file system.
  • Minimum 1 GB of free space on the system partition.
  • Minimum 2 GB of free space on the volume on which the database is stored.
  • Minimum 20 GB of free space on the volume on which updates are stored; however, 30 GB is recommended.

WSUS server software requirements:

The following requirements identify the minimum operating system versions, application software, and database software for a WSUS server. The server must have one of the following operating systems installed:

  • Windows Server 2008 R2
  • Windows Server 2008 with SP2 or Windows Server 2008 with Service Pack 1 (SP1)
  • Windows Server 2003 with SP2
  • Windows® Small Business Server 2011, Windows Small Business Server 2008, or Windows Small Business Server 2003 with SP2

The server must also be running all of the following application software:

  • At least Internet Information Services (IIS) 6.0
  • At least Microsoft® .NET Framework 2.0
  • At least Microsoft Management Console 3.0
  • At least Microsoft Report Viewer Redistributable 2008

WSUS database requirements:

WSUS 3.0 SP2 requires a SQL Server database, which must be at least one of the following versions or editions:

  • Windows Internal Database
  • Microsoft SQL Server 2008 Standard or Enterprise Edition
  • Microsoft SQL Server 2005 with SP3
  • Microsoft SQL Server 2005 Express Edition with SP3

WSUS Administration Console software requirements:

Any computer that runs the WSUS Administration Console must have one of the following operating systems installed:

  • At least Windows Server 2008 R2
  • At least Windows Server 2008 with Service Pack 1 (SP1)
  • At least Windows Server 2003 with SP2
  • At least Windows Small Business Server 2003 with SP2
  • Windows 7
  • Windows Vista®
  • Windows XP with Service Pack 3 (SP3)

Any computer that runs the WSUS Administration Console must also have all of the following software installed:

  • At least The Microsoft .NET Framework 2.0
  • At least Microsoft Management Console 3.0
  • At least Microsoft Report Viewer Redistributable 2008

The computer that runs the WSUS Administration Console must be in the same Active Directory domain as the WSUS server, or it must have a trust relationship with the Active Directory domain of the WSUS server.

WSUS client system requirements

Automatic Updates is the client software that operates with WSUS. Automatic Updates can be installed and used on any computer that is running one of the following operating systems:

  • Windows 7
  • Windows Vista
  • Windows XP Professional
  • Windows Server 2008 R2
  • Windows Server 2008 with Service Pack 1 (SP1)
  • Windows Small Business Server 2008
  • Windows Small Business Server 2005
  • Windows Small Business Server 2003 or later versions
  • Microsoft Windows Server 2000 with Service Pack 4 (SP4)

To Know How To Setup & Configure Windows Server Update Services (WSUS).

POSTS YOU MAY LIKE -:)

Share This Post

Shares